Spotify en Crunchbang GNULinux

Hace tiempo que estaba tentado de usar spotify pero no había buscado nada, hasta ahora. Google me contó que hay una versión nativa para GNULinux y genial, busqué como instalarla. Dificilmente podría haber sido más fácil, sin embargo me encontré con un problemilla. Lo resolví y ahora escribo esto para compartir la solución.

Las indicaciones las da Spotify mismo en su sitio y son las siguientes:

  • edita /etc/apt/sources.list y añade esta línea a tu lista de repositorios
    deb http://repository.spotify.com stable non-free
  • añade nuestra clave pública
    sudo apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys 94558F59>
  • Actualiza los repositorios con
    sudo apt-get update
  • Instala Spotify
    sudo apt-get install spotify-client

En el último paso tuve el siguiente problema:
camilo@lucifer:~$ sudo apt-get install spotify-client
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
No se pudieron instalar algunos paquetes. Esto puede significar que usted
pidió una situación imposible o, si está usando la distribución inestable,
que algunos paquetes necesarios no han sido creados o han sido movidos fuera
de Incoming.
La siguiente información puede ayudar a resolver la situación:
Los siguientes paquetes tienen dependencias incumplidas:
spotify-client : Depende: libssl0.9.8 pero no es instalable
E: No se pudieron corregir los problemas, usted ha retenido paquetes rotos.

Aun cuando lo dice con todas sus letras, que la librería necesaria (libssl0.9.8) no es instalable, intenté instalarla y no estaba en los repositorios. Busqué en internet y poco tardé en caer en cuenta que la librería necesaria sí existe, pero sólo está para Debian Squeeze (recordemos que Crunchbang está basado en Debian Wheezy). Apreté los dientes y aperré: instale una librería oldstable en una distro stable. ¿El resultado? Exito.

Para instalar libssl0.9.8, bajen el archivo .deb de alguno de los mirrors y luego lo instalan con el viejo amigo dpkg
camilo@lucifer:~$ sudo dpkg -i Descargas/libssl0.9.8_0.9.8o-4squeeze14_i386.deb>
Luego, intentamos instalar spotify-client
camilo@lucifer:~$ sudo dpkg apt-get install spotify-client
Y listo 🙂

Plus: existe un bug con las radios y no funcionan, solucionarlo es muy simple. Hay que editar el archivo /usr/share/applications/spotify.desktop y modificar la línea que empieza con “Exec” para que quede así:

Exec=env LC_NUMERIC=en_US.utf8 spotify %U

Y, ahora sí que listo para ocupar todo el potencial de Spotify.

← Entrada anterior

Entrada siguiente →

2 Comentarios

  1. Bueno que pudiste resolver el problema de la radio, cual era la linea original?

  2. Camilo Villavicencio Garrido

    La línea original era
    Exec= spotify %U
    que simplemente llama al programa para que funcione. :3

Los comentarios están cerrados.